Закрыть

Примеры схем – Примеры блок-схем, организованных диаграмм и других

Содержание

примеры, элементы, построение. Блок-схемы алгоритмов :: SYL.ru

В этой статье будут рассмотрены примеры блок-схем, которые могут встретиться вам в учебниках по информатике и другой литературе. Блок-схема представляет собой алгоритм, по которому решается какая-либо задача, поставленная перед разработчиком. Сначала нужно ответить на вопрос, что такое алгоритм, как он представляется графически, а самое главное – как его решить, зная определенные параметры. Нужно сразу отметить, что алгоритмы бывают нескольких видов.

Что такое алгоритм?

Это слово ввел в обиход математик Мухаммед аль-Хорезми, который жил в период 763-850 года. Именно он является человеком, который создал правила выполнения арифметических действий (а их всего четыре). А вот ГОСТ от 1974 года, который гласит, что:

Алгоритм – это точное предписание, которое определяет вычислительный процесс. Причем имеется несколько переменных с заданными значениями, которые приводят расчеты к искомому результату.

Алгоритм позволяет четко указать исполнителю выполнять строгую последовательность действий, чтобы решить поставленную задачу и получить результат. Разработка алгоритма – это разбивание одной большой задачи на некую последовательность шагов. Причем разработчик алгоритма обязан знать все особенности и правила его составления.

Особенности алгоритма

Всего можно выделить восемь особенностей алгоритма (независимо от его вида):

  1. Присутствует функция ввода изначальных данных.
  2. Есть вывод некоего результата после завершения алгоритма. Нужно помнить, что алгоритм нужен для того, чтобы достичь определенной цели, а именно – получить результат, который имеет прямое отношение к исходным данным.
  3. У алгоритма должна быть структура дискретного типа. Он должен представляться последовательными шагами. Причем каждый следующий шаг может начаться только после завершения предыдущего.
  4. Алгоритм должен быть однозначным. Каждый шаг четко определяется и не допускает произвольной трактовки.
  5. Алгоритм должен быть конечным – необходимо, чтобы он выполнялся за строго определенное количество шагов.
  6. Алгоритм должен быть корректным – задавать исключительно верное решение поставленной задачи.
  7. Общность (или массовость) – он должен работать с различными исходными данными.
  8. Время, которое дается на решение алгоритма, должно быть минимальным. Это определяет эффективность решения поставленной задачи.

А теперь, зная, какие существуют блок-схемы алгоритмов, можно приступить к рассмотрению способов их записи. А их не очень много.

Словесная запись

Такая форма, как правило, применяется при описании порядка действий для человека: «Пойди туда, не знаю куда. Принеси то, не знаю что».

Конечно, это шуточная форма, но суть понятна. В качестве примера можно привести еще, например, привычную запись на стеклах автобусов:«При аварии выдернуть шнур, выдавить стекло».

Здесь четко ставится условие, при котором нужно выполнить два действия в строгой последовательности. Но это самые простые алгоритмы, существуют и более сложные. Иногда используются формулы, спецобозначения, но при обязательном условии – исполнитель должен все понимать.

Допускается изменять порядок действий, если необходимо вернуться, например, к предыдущей операции либо обойти какую-то команду при определенном условии. При этом команды желательно нумеровать и обязательно указывается команда, к которой происходит переход: «Закончив все манипуляции, повторяете пункты с 3 по 5».

Запись в графической форме

В этой записи участвуют элементы блок-схем. Все элементы стандартизированы, у каждой команды имеется определенная графическая запись. А конкретная команда должна записываться внутри каждого из блоков обычным языком или математическими формулами. Все блоки должны соединяться линиями – они показывают, какой именно порядок у выполняемых команд. Собственно, этот тип алгоритма более подходит для использования в программном коде, нежели словесный.

Запись на языках программирования

В том случае, если алгоритм необходим для того, чтобы задачу решала программа, установленная на ПК, то нужно его записывать специальным кодом. Для этого существует множество языков программирования. И алгоритм в этом случае называется программой.

Блок-схемы

Блок-схема – это представление алгоритма в графической форме. Все команды и действия представлены геометрическими фигурами (блоками). Внутри каждой фигуры вписывается вся информация о тех действиях, которые нужно выполнить. Связи изображены в виде обычных линий со стрелками (при необходимости).

Для оформления блок-схем алгоритмов имеется ГОСТ 19.701-90. Он описывает порядок и правила создания их в графической форме, а также основные методы решения. В этой статье приведены основные элементы блок-схем, которые используются при решении задач, например, по информатике. А теперь давайте рассмотрим правила построения.

Основные правила составления блок-схемы

Можно выделить такие особенности, которые должны быть у любой блок-схемы:

  1. Обязательно должно присутствовать два блока – «Начало» и «Конец». Причем в единичном экземпляре.
  2. От начального блока до конечного должны быть проведены линии связи.
  3. Из всех блоков, кроме конечного, должны выходить линии потока.
  4. Обязательно должна присутствовать нумерация всех блоков: сверху вниз, слева направо. Порядковый номер нужно проставлять в левом верхнем углу, делая разрыв начертания.
  5. Все блоки должны быть связаны друг с другом линиями. Именно они должны определять последовательность, с которой выполняются действия. Если поток движется снизу вверх или справа налево (другими словами, в обратном порядке), то обязательно рисуются стрелки.
  6. Линии делятся на выходящие и входящие. При этом нужно отметить, что одна линия является для одного блока выходящей, а для другого входящей.
  7. От начального блока в схеме линия потока только выходит, так как он является самым первым.
  8. А вот у конечного блока имеется только вход. Это наглядно показано на примерах блок-схем, которые имеются в статье.
  9. Чтобы проще было читать блок-схемы, входящие линии изображаются сверху, а исходящие снизу.
  10. Допускается наличие разрывов в линиях потока. Обязательно они помечаются специальными соединителями.
  11. Для облегчения блок-схемы разрешается всю информацию прописывать в комментариях.

Графические элементы блок-схем для решения алгоритмов представлены в таблице:

Линейный тип алгоритмов

Это самый простой вид, который состоит из определенной последовательности действий, они не зависят от того, какие данные вписаны изначально. Есть несколько команд, которые выполняются однократно и только после того, как будет сделана предшествующая. Линейная блок-схема выглядит таким образом:

Пример линейного алгоритма

Причем связи могут идти как сверху вниз, так и слева направо. Используется такая блок-схема для записи алгоритмов вычислений по простым формулам, у которых не имеется ограничений на значения переменных, входящих в формулы для расчета. Линейный алгоритм – это составная часть сложных процессов вычисления.

Разветвляющиеся алгоритмы

Блок-схемы, построенные по таким алгоритмам, являются более сложными, нежели линейные. Но суть не меняется. Разветвляющийся алгоритм – это процесс, в котором дальнейшее действие зависит от того, как выполняется условие и какое получается решение. Каждое направление действия – это ветвь.

Разновидности циклов для решения алгоритмов

На схемах изображаются блоки, которые называются «Решение». У него имеется два выхода, а внутри прописывается логическое условие. Именно от того, как оно будет выполнено, зависит дальнейшее движение по схеме алгоритма. Можно разделить разветвляющиеся алгоритмы на три группы:

  1. «Обход» – при этом одна из веток не имеет операторов. Другими словами, происходит обход нескольких действий другой ветки.
  2. «Разветвление» – каждая ветка имеет определенный набор выполняемых действий.
  3. «Множественный выбор» – это разветвление, в котором есть несколько веток и каждая содержит в себе определенный набор выполняемых действий. Причем есть одна особенность – выбор направления напрямую зависит от того, какие заданы значения выражений, входящих в алгоритм.

Это простые алгоритмы, которые решаются очень просто. Теперь давайте перейдем к более сложным.

Циклический алгоритм

Здесь все предельно понятно – циклическая блок-схема представляет алгоритм, в котором многократно повторяются однотипные вычисления. По определению, цикл – это определенная последовательность каких-либо действий, выполняемая многократно (более, чем один раз). И можно выделить несколько типов циклов:

  1. У которых известно число повторений действий (их еще называют циклами со счетчиком).
  2. У которых число повторений неизвестно – с постусловием и предусловием.

Независимо от того, какой тип цикла используется для решения алгоритма, у него обязательно должна присутствовать переменная, при помощи которой происходит выход. Именно она определяет количество повторений цикла. Рабочая часть (тело) цикла – это определенная последовательность действий, которая выполняется на каждом шаге. А теперь более детально рассмотрим все типы циклов, которые могут встретиться при составлении алгоритмов и решении задач по информатике.

Циклы со счетчиками

На рисунке изображена простая блок-схема, в которой имеется цикл со счетчиком. Такой тип алгоритмов показывает, что заранее известно количество повторений данного цикла. И это число фиксировано. При этом переменная, считающая число шагов (повторений), так и называется – счетчик. Иногда в учебниках можно встретить иные определения – параметр цикла, управляющая переменная.

Изображение цикла со счетчиком

Блок-схема очень наглядно иллюстрирует, как работает цикл со счетчиком. Прежде чем приступить к выполнению первого шага, нужно присвоить начальное значение счетчику – это может быть любое число, оно зависит от конкретного алгоритма. В том случае, когда конечное значение меньше величины счетчика, начнет выполняться определенная группа команд, которые составляют тело цикла.

После того, как тело будет выполнено, счетчик меняется на величину шага счетчика, обозначенную буквой h. В том случае, если значение, которое получится, будет меньше конечного, цикл будет продолжаться. И закончится он лишь в тогда, когда конечное значение будет меньше, чем счетчик цикла. Только в этом случае произойдет выполнение того действия, которое следует за циклом.

Как изображается счетчик цикла

Обычно в обозначениях блок-схем используется блок, который называется «Подготовка». В нем прописывается счетчик, а затем указываются такие данные: начальное и конечное значения, шаг изменения. На блок-схеме это параметры I н, Ik и h, соответственно. В том случае, когда h=1, величину шага не записывают. В остальных случаях делать это обязательно. Необходимо придерживаться простого правила – линия потока должна входить сверху. А линия потока, которая выходит снизу (или справа, в зависимости от конкретного алгоритма), должна показывать переход к последующему оператору.

Теперь вы полностью изучили описание блок-схемы, изображенной на рисунке. Можно перейти к дальнейшему изучению. Когда используется цикл со счетчиком, требуется соблюдать определенные условия:

  1. В теле не разрешается изменять (принудительно) значение счетчика.
  2. Запрещено передавать управление извне оператору тела. Другими словами, войти в цикл можно только из его начала.

Циклы с предусловием

Этот тип циклов применяется в тех случаях, когда количество повторений заранее неизвестно. Цикл с предусловием – это тип алгоритма, в котором непосредственно перед началом выполнения тела осуществляется проверка условия, при котором допускается переход к следующему действию. Обратите внимание на то, как изображаются элементы блок-схемы.

В том случае, когда условие выполняется (утверждение истинно), происходит переход к началу тела цикла. Непосредственно в нем изменяется значение хотя бы одной переменной, влияющей на значение поставленного условия. Если не придерживаться этого правила, получим «зацикливание». В том случае, если после следующей проверки условия выполнения тела цикла оказывается, что оно ложное, то происходит выход.

В блок-схемах алгоритмов допускается осуществлять проверку не истинности, а ложности начального условия. При этом из цикла произойдет выход только в том случае, если значение условия окажется истинным. Оба варианта правильные, их использование зависит от того, какой конкретно удобнее использовать для решения той или иной задачи. Такой тип цикла имеет одну особенность – тело может не выполниться в случае, когда условие ложно или истинно (в зависимости от варианта, который применяется для решения алгоритма).

Ниже приведена блок-схема, которая описывает все эти действия:

Изображение цикла с предусловием

Если внимательно присмотреться, то этот вид циклов чем-то похож на предыдущий. Самостоятельно построить блок-схему, описывающую этот цикл, мы сейчас и попробуем. Особенность заключается в том, что неизвестно заранее число повторений. А условие задается уже после того, как произошел выход из тела. Отсюда видно, что тело, независимо от решения, будет выполняться как минимум один раз. Для наглядности взгляните на блок-схему, описывающую выполнение условия и операторов:

Изображение цикла с постусловием

Ничего сложного в построении алгоритмов с циклами нет, достаточно в них только один раз разобраться. А теперь перейдем к более сложным конструкциям.

Сложные циклы

Сложные – это такие конструкции, внутри которых есть один или больше простых циклов. Иногда их называют вложенными. При этом те конструкции, которые охватывают иные циклы, называют «внешними». А те, которые входят в конструкцию внешних – внутренними. При выполнении каждого шага внешнего цикла происходит полная прокрутка внутреннего, как представлено на рисунке:

Пример сложного цикла

Вот и все, вы рассмотрели основные особенности построения блок-схем для решения алгоритмов, знаете принципы и правила. Теперь можно рассмотреть конкретные примеры блок-схем из жизни. Например, в психологии такие конструкции используются для того, чтобы человек решил какой-то вопрос:

Пример из жизни решения алгоритма

Или пример из биологии для решения поставленной задачи:

Второй пример решения алгоритма по блок-схеме

Решение задач с блок-схемами

А теперь рассмотрим примеры задач с блок-схемами, которые могут попасться в учебниках информатики. Например, задана блок-схема, по которой решается какой-то алгоритм:

Решение задачи по математике

При этом пользователь самостоятельно вводит значения переменных. Допустим, х=16, а у=2. Процесс выполнения такой:

  1. Производится ввод значений х и у.
  2. Выполняется операция преобразования: х=√16=4.
  3. Выполняется условие: у=у2=4.
  4. Производится вычисление: х=(х+1)=(4+1)=5.
  5. Дальше вычисляется следующая переменная: у=(у+х)=(5+4)=9.
  6. Выводится решение: у=9.

На этом примере блок-схемы по информатике хорошо видно, как происходит решение алгоритма. Нужно обратить внимание на то, что значения х и у задаются на начальном этапе и они могут быть любыми.

www.syl.ru

Схемы — урок. Информатика, 6 класс.

В повседневной жизни нас окружает множество разнообразных схем: схемы проезда, схемы дорожных развязок, схема метрополитена, схема расположения мест в зрительном зале, схема движения пригородных электропоездов и многое другое.

Схема — это представление некоторого объекта в общих, главных чертах с помощью условных обозначений. С помощью схемы может быть представлен и внешний вид объекта, и его структура.

Например, внешний вид зрительного зала:

 

 

Представление о внешнем виде квартиры:

 

 

Представлена схема метро:


Уменьшенное обобщённое изображение поверхности Земли на плоскости в той или иной системе условных обозначений дает нам географическая карта. На карте изображён внешний вид территории северо-восточной части Центральной России. На ней показаны древние русские города, образующие знаменитое на весь мир Золотое кольцо.


 

Представленные схемы являются информационными моделями внешнего вида соответствующих объектов. Они предназначены для того, чтобы у человека была возможность, например, выбрать подходящее место в зрительном зале, оценить размеры и расположение комнат будущей квартиры, разработать маршрут путешествия по Золотому кольцу, добраться до Бородинского поля и т. д.

 

Для этих моделей большое значение имеет соблюдение масштаба. Для схемы проезда и карты также значение имеет соблюдение ориентации по сторонам света. Но, несмотря на точность рассмотренных информационных моделей, более подробные сведения об изображённых на них объектах (местах в зале, домах, дорогах, городах) из них получить нельзя.

 

Схема как информационная модель не претендует на полноту предоставления информации об объекте. С помощью особых приёмов и графических обозначений на ней более рельефно выделяется один или несколько признаков рассматриваемого объекта.

 

Например, туристический маршрут «Золотое кольцо России» более образно запечатлён на схеме:

 

 

Здесь не полностью выдержан масштаб, но зато акцентировано внимание на городах, образующих Золотое кольцо, и их достопримечательностях.

Чертежи — условные графические изображения предметов с точным соотношением их размеров, получаемые методом проецирования.

Рисунок содержит изображения, размерные числа, текст. Изображения дают представления о геометрической форме детали, числа — о величине детали и её частей, надписи — о названии, масштабе, в котором выполнены изображения, материале, из которого изготовлена деталь.

 

Источники:

Босова Л. Л., Информатика и ИКТ : учебник для 6 класса. М. : БИНОМ. Лаборатория знаний, 100 с.

www.yaklass.ru

Как составить схему предложения: основные виды с примерами

Павел Ямб

Привет двоечники. Бродил недавно по просторам интернета и наткнулся на учебник по русскому языку. Вспомнил эту школу, в которую приходилось ходить каждый день и просиживать штаны. Несмотря на то, что я всегда учился ну…. скажем неплохо, повторить этот опыт я бы не хотел. В учебнике нашёл урок про то, как правильно составляется структура предложений.  И решил написать про это статью, чтобы вы, застигнутые ностальгией по школьным временам, или, вдруг, необходимостью, не бродили в поисках учебниках по русскому языку, а пришли ко мне в блог. И вот вам стразу проверка:

Лимит времени: 0

Информация

Этот тест покажет насколько вы разбираетесь в схемах предложений (1 уровень сложности)

Вы уже проходили тест ранее. Вы не можете запустить его снова.

Тест загружается...

Вы должны войти или зарегистрироваться для того, чтобы начать тест.

Вы должны закончить следующие тесты, чтобы начать этот:

Время вышло

Вы набрали 0 из 0 баллов (0)

Ваш результат был записан в таблицу лидеров
  1. С ответом
  2. С отметкой о просмотре
  1. Задание 1 из 10

    Найдите среди представленных предложений структуру [ __ и __ ====== ]

  2. Задание 2 из 10

    Найдите среди представленных предложений структуру [│О│,…]

  3. Задание 3 из 10

    Найдите среди представленных предложений структуру [│ВВ│,…].

  4. Задание 4 из 10

    Найдите среди представленных предложений структуру [│ДО│, Х …].

  5. Задание 5 из 10

    Найдите среди представленных предложений структуру [ Х,│ ПО│,…].

  6. Задание 6 из 10

    Найдите среди представленных предложений структуру «[П!]»- [а].

  7. Задание 7 из 10

    Найдите среди представленных предложений структуру «[П..,│О│!] — [а]. — [│ВВ│,…П..]».

  8. Задание 8 из 10

    Найдите среди представленных предложений структуру […..], и […..].

  9. Задание 9 из 10

    Найдите среди представленных предложений структуру […..], (что ….).

  10. Задание 10 из 10

    Найдите среди представленных предложений структуру […..], (который ….).

максимум из 100 баллов
МестоИмяЗаписаноБаллыРезультат
Таблица загружается
Нет данных

Кто-то возразит: «Школа давно закончилась, напишем без схем». Такая точка зрения вполне справедлива. Для тех, кто общается с помощью СМС и игровых чатов.  Итак, сегодня тема нашего занятия звучит так: «Как составить схему предложения?»  Тем более если вы копирайтер или хотите им стать и зарабатывать больше чем ваша училка, знание схем предложений, к сожалению, необходимо.

Порядок составления схемы предложения

  1. Определить тип предложения по цели высказывания и по интонации. Предложения по цели высказывания делаться: на повествовательные, вопросительные, побудительные. По эмоциональной окраске – восклицательные и невосклицательные.
  2. Найти основу – подлежащее и сказуемое. Основа ‑ это главная мысль предложения, та важная информация, которую мы хотим донести.Составление схемы предложений
  3. Определить тип предложения по строению: простое или сложное.
  4. Разбить сложное предложение на простые составляющие. Отметить границы простых предложений.
  5. Выделить причастный или деепричастный оборот, проследить перечисления.
  6. Определить союзную связь. Проверить правильность применения сочинительного или подчинительного союза.

Для составления схемы понадобятся графические обозначения. Равноправные предложения в составе сложного предложения обозначим квадратными скобками. Подчиненное вместе с союзом – круглыми скобками. Главное слово, от которого задается вопрос, — крестиком.

Схемы предложений

Схема простого предложения

Рассмотрим сразу пример. Начнем с самого легкого задания для начальной школы.

Screenshot_1

Это простое двухсоставное предложение. Различают также односоставное, когда главные члены предложения выражены одним подлежащим или одним сказуемым. Простые предложения бывают распространенными, как в нашем случае, или нераспространенными, к примеру:

Screenshot_2

Обращаем внимание на сказуемое. Оно может быть простым или сложным:

  • Простым: «Михаил сочинял».
  • Составным глагольным: «Миша хотел писать на диване».
  • Составным именным: «Миша был другом для меня».

В простом предложении может быть обращение:

Иван, сядь в левый ряд. Схема предложения следующая

[│О│,…..].

Важно выделить обращение запятыми так же, как и вводные слова.

К несчастью, такое случалось довольно часто

[│ВВ│,…..].

Не забываем найти и выделить деепричастный или причастный обороты.

Не отрывая глаз, смотрел на нее пес

[│ДО│, Х …].

Вид, открывшийся перед ним, был похож на зачарованное царство холода.

 [ Х,│ ПО│, …..].

В литературных текстах, в текстах-рассуждениях часто встречается прямая речь.

«Не заходи во двор!»- громко крикнул незнакомец.

«[П!]»- [а].

«Ура, братцы!- закричал он. – Кажется, наше дело начинает идти на лад».

«[П..,│О│!] — [а]. — [│ВВ│,…П..]».

Итак, училка по английскому. Представьте у меня все пятерки (80 процентов), я иду на красный диплом техникума, олимпиады, конференции – меня знают все. И эта…... ну…. женщина ставит мне тряк. Я ей говорю: вы что не нормальная, посмотрите на мои оценки, вы что творите? И нифига – якобы принцип. Хотя какой на хер принцип, когда она ставила четверки спортсменам, которые не приходили вообще на пары и за банку кофе ставила пятерки. И ей все это говорили, Паше надо поставить хотя бы четверку.  Короче жесть. Уже на защите диплома вмешался сам директор и она поставила мне 4 уже после защиты, но красный диплом был потерян.

Схема сложного предложения.

Различают несколько видов сложных предложений. Рассмотрим их по порядку.

Сложносочиненное — это два простых равноправных предложения, соединенные сочинительным союзом.

Стены тоннеля раздвинулись, и путешественники очутились в огромном подлунном гроте.

Схема здесь несложная […..], и […..].

В сложноподчиненном предложении одна часть главная, вторая подчиняется, сопутствует первой.

Отдельные колонны были так огромны, что доставали своими вершинами до самого свода.

[…..], (что ….).

Окружающий воздух был намного чище того, который он вдыхал дома.

[…..], (которым ….).

Подчинение в таких предложениях происходит с помощью подчинительных союзов.

Бессоюзное предложение аналогично сложносочиненному, но не имеет союза.

Телевизионная студия предлагала смехотворно малую сумму – Мига рассердился.

[…..] — […..].

В нашем примере недовольство Миги вызвано действиями, произведенными в первой части сложного предложения. Но союза нет, его заменяет знак тире.

Не запутайтесь, составляя схему с разными типами связи. Разбить такие предложения, при этом не потеряв главную мысль, бывает очень сложно.

Дно тоннеля уходило вниз, поэтому идти было легко и просто: казалось, кто-то толкает в спину, и впереди скоро зажжется свет.

 […..], (поэтому ….): [│ВВ│,...], и [....].

Сложное предложение может иметь несколько придаточных частей, вытекающих одно из другого. Это последовательное подчинение.

Ребятам сообщили, что завтра будет праздник, который закончится карнавальным шествием.

[…..],

↓ что?

 (что ….),

↓ какой?

 (который ….).

Различают также параллельное подчинение. От главного предложения задаются разные вопросы к придаточным частям. Придаточные части в данном случае могут практически без изменения сделаться отдельными простыми предложениями.

Когда пришел фотограф, Серенький завернул акцию в платочек, чтобы спрятать ее за пазуху.

                      […..]

↓ когда?                   ↓ зачем?

 (когда ….),             (чтобы ….).

В русском языке выделяют однородное подчинение. Это перечисление простых предложений. К ним задается одинаковый вопрос от главной части, и соединяются они одинаковым союзом.

Наблюдая весной за природой, можно заметить, как прилетают птицы, как появляются нежные листочки, как зацветают первые цветы.

                      […..]

↓ что?            ↓ что?            ↓ что?

 (как ….),     (как ….),      (как ….).

Основные виды предложений рассмотрены. Читая и анализируя текст, внимательно просматривайте большие по конструкции предложения. Выделяйте главную информацию. Мысленно задавайте вопросы от главного слова или главной части к придаточной или подчиненной. Это поможет уловить суть и правильно расставить знаки препинания.

Всем творческих успехов. Ну и найдите 10 отличий на этих картинках и напишите за сколько у вас это получилось сделать.

Подарок от нашего художникаНайди 10 отличий
Подарок от нашего художника

copirayter.ru

Использование драйвера ключей нижнего и верхнего уровней IR2110 — объяснение и примеры схем

Быть может, после прочтения этой статьи вам не придётся ставить такие же по размерам радиаторы на транзисторы.
Перевод этой статьи.

Небольшое обращение от переводчика:Во-первых, в данном переводе могут быть серьёзные проблемы с переводом терминов, я не занимался электротехникой и схемотехникой достаточно, но всё же что-то знаю; также я пытался перевести всё максимально понятно, поэтому не использовал такие понятия, как бутсрепный, МОП-транзистор и т.п. Во-вторых, если орфографически сейчас уже сложно сделать ошибку (хвала текстовым процессорам с указанием ошибок), то ошибку в пунктуации сделать довольно-таки просто.
И вот по этим двум пунктам прошу пинать меня в комментариях как можно сильнее.

Теперь поговорим уже больше о теме статьи — при всём многообразии статей о построении различных транспортных средств наземного вида (машинок) на МК, на Arduino, на <вставить название>, само проектирование схемы, а тем более схемы подключения двигателя не описывается достаточно подробно. Обычно это выглядит так:
— берём двигатель
— берём компоненты
— подсоединяем компоненты и двигатель
— …
— PROFIT!1!

Но для построения более сложных схем, чем для простого кручения моторчика с ШИМ в одну сторону через L239x, обычно требуется знание о полных мостах (или H-мостах), о полевых транзисторах (или MOSFET), ну и о драйверах для них. Если ничто не ограничивает, то можно использовать для полного моста p-канальные и n-канальные транзисторы, но если двигатель достаточно мощный, то p-канальные транзисторы придётся сначала обвешивать большим количеством радиаторов, потом добавлять кулеры, ну а если совсем их жалко выкидывать, то можно попробовать и другие виды охлаждения, либо просто использовать в схеме лишь n-канальные транзисторы. Но с n-канальными транзисторами есть небольшая проблема — открыть их «по-хорошему» подчас бывает довольно сложно.

Поэтому я искал что-нибудь, что мне поможет с составлением правильной схемы, и я нашёл статью в блоге одного молодого человека, которого зовут Syed Tahmid Mahbub. Этой статьёй я и решил поделится.


Во многих ситуациях мы должны использовать полевые транзисторы как ключи верхнего уровня. Также во многих ситуациях мы должны использовать полевые транзисторы как ключи как и верхнего, так и нижнего уровней. Например, в мостовых схемах. В неполных мостовых схемах у нас есть 1 MOSFET верхнего уровня и 1 MOSFET нижнего уровня. В полных мостовых схемах мы имеем 2 MOSFETа верхнего уровня и 2 MOSFETа нижнего уровня. В таких ситуациях нам понадобится использовать драйвера как высокого, так и низкого уровней вместе. Наиболее распространённым способом управления полевыми транзисторами в таких случаях является использование драйвера ключей нижнего и верхнего уровней для MOSFET. Несомненно, самым популярным микросхемой-драйвером является IR2110. И в этой статье/учебнике я буду говорить о именно о нём.

Вы можете загрузить документацию для IR2110 с сайта IR. Вот ссылка для загрузки: http://www.irf.com/product-info/datasheets/data/ir2110.pdf

Давайте для начала взглянем на блок-схему, а также описание и расположение контактов:


Рисунок 1 — Функциональная блок-схема IR2110


Рисунок 2 — Распиновка IR2110


Рисунок 3 — Описание пинов IR2110

Также стоит упомянуть, что IR2110 выпускается в двух корпусах — в виде 14-контактного PDIP для выводного монтажа и 16-контактного SOIC для поверхностного монтажа.

Теперь поговорим о различных контактах.

VCC — это питание нижнего уровня, должно быть между 10В и 20В. VDD — это логическое питание для IR2110, оно должно быть между +3В и +20В (по отношению к VSS). Фактическое напряжение, которое вы выберете для использования, зависит от уровня напряжения входных сигналов. Вот график:


Рисунок 4 — Зависимость логической 1 от питания

Обычно используется VDD равное +5В. При VDD = +5В, входной порог логической 1 немного выше, чем 3В. Таким образом, когда напряжение VDD = +5В, IR2110 может быть использован для управления нагрузкой, когда вход «1» выше, чем 3 (сколько-то) вольт. Это означает, что IR2110 может быть использован почти для всех схем, так как большинство схем, как правило, имеют питание примерно 5В. Когда вы используете микроконтроллеры, выходное напряжение будет выше, чем 4В (ведь микроконтроллер довольно часто имеет VDD = +5В). Когда используется SG3525 или TL494 или другой ШИМ-контроллер, то, вероятно, придётся их запитывать напряжением большим, чем 10В, значит на выходах будет больше, чем 8В, при логической единице. Таким образом, IR2110 может быть использован практически везде.

Вы также можете снизить VDD примерно до +4В, если используете микроконтроллер или любой чип, который даёт на выходе 3.3В (например, dsPIC33). При проектировании схем с IR2110, я заметил, что иногда схема не работает должным образом, когда VDD у IR2110 был выбран менее + 4В. Поэтому я не рекомендую использовать VDD ниже +4В. В большинстве моих схем уровни сигнала не имеют напряжение меньше, чем 4В как «1», и поэтому я использую VDD = +5V.

Если по каким-либо причинам в схеме уровень сигнала логической «1» имеет напряжение меньшее, чем 3В, то вам нужно использовать преобразователь уровней/транслятор уровней, он будет поднимать напряжение до приемлемых пределов. В таких ситуациях я рекомендую повышение до 4В или 5В и использование у IR2110 VDD = +5В.

Теперь давайте поговорим о VSS и COM. VSS это земля для логики. COM это «возврат низкого уровня» — в основном, заземление низкого уровня драйвера. Это может выглядеть так, что они являются независимыми, и можно подумать что, пожалуй, было бы возможно изолировать выходы драйвера и сигнальную логику драйвера. Тем не менее, это было бы неправильно. Несмотря на то что внутренне они не связаны, IR2110 является неизолированным драйвером, и это означает, что VSS и COM должны быть оба подключены к земле.

HIN и LIN это логические входы. Высокий сигнал на HIN означает, что мы хотим управлять верхним ключом, то есть на HO осуществляется вывод высокого уровня. Низкий сигнал на HIN означает, что мы хотим отключить MOSFET верхнего уровня, то есть на HO осуществляется вывод низкого уровня. Выход в HO, высокий или низкий, считается не по отношению к земле, а по отношению к VS. Мы скоро увидим, как усилительные схемы (диод + конденсатор), используя VCC, VB и VS, обеспечивают плавающее питания для управления MOSFETом. VS это плавающий возврат питания. При высоком уровне, уровень на HO равен уровню на VB, по отношению к VS. При низком уровне, уровень на HO равнен VS, по отношению к VS, фактически нулю.

Высокий сигнал LIN означает, что мы хотим управлять нижним ключом, то есть на LO осуществляется вывод высокого уровня. Низкий сигнал LIN означает, что мы хотим отключить MOSFET нижнего уровня, то есть на LO осуществляется вывод низкого уровня. Выход в LO считается относительно земли. Когда сигнал высокий, уровень в LO такой же как и в VCC, относительно VSS, фактически земля. Когда сигнал низкий, уровень в LO такой же как и в VSS, относительно VSS, фактически нуль.

SD используется в качестве контроля останова. Когда уровень низкий, IR2110 включен — функция останова отключена. Когда этот вывод является высоким, выходы выключены, отключая управление IR2110.
Теперь давайте взглянем на частые конфигурации с IR2110 для управления MOSFETами как верхних и нижних ключей — на полумостовые схемы.


Рисунок 5 — Базовая схема на IR2110 для управления полумостом

D1, C1 и C2 совместно с IR2110 формируют усилительную цепь. Когда LIN = 1 и Q2 включен, то C1 и С2 заряжаются до уровня VB, так как один диод расположен ниже +VCC. Когда LIN = 0 и HIN = 1, заряд на C1 и С2 используется для добавления дополнительного напряжения, VB в данном случае, выше уровня источника Q1 для управления Q1 в конфигурации верхнего ключа. Достаточно большая ёмкость должна быть выбрана у C1 для того чтобы её хватило для обеспечения необходимого заряда для Q1, чтобы Q1 был включён всё это время. C1 также не должен иметь слишком большую ёмкость, так как процесс заряда будет проходить долго и уровень напряжения не будет увеличиваться в достаточной степени чтобы сохранить MOSFET включённым. Чем большее время требуется во включённом состоянии, тем большая требуется ёмкость. Таким образом меньшая частота требует большую ёмкость C1. Больший коэффициент заполнения требует большую ёмкость C1. Конечно есть формулы для расчёта ёмкости, но для этого нужно знать множество параметров, а некоторые из них мы может не знать, например ток утечки конденсатора. Поэтому я просто оценил примерную ёмкость. Для низких частот, таких как 50Гц, я использую ёмкость от 47мкФ до 68мкФ. Для высоких частот, таких как 30-50кГц, я использую ёмкость от 4.7мкФ до 22мкФ. Так как мы используем электролитический конденсатор, то керамический конденсатор должен быть использован параллельно с этим конденсатором. Керамический конденсатор не обязателен, если усилительный конденсатор — танталовый.

D2 и D3 разряжают затвор MOSFETов быстро, минуя затворные резисторы и уменьшая время отключения. R1 и R2 это токоограничивающие затворные резисторы.

+MOSV может быть максимум 500В.

+VCC должен идти с источника без помех. Вы должны установить фильтрующие и развязочные конденсаторы от +VCC к земле для фильтрации.

Давайте теперь рассмотрим несколько примеров схем с IR2110.


Рисунок 6 — Схема с IR2110 для высоковольтного полумоста


Рисунок 7 — Схема с IR2110 для высоковольтного полного моста с независимым управлением ключами (кликабельно)

На рисунке 7 мы видим IR2110, использованный для управления полным мостом. В ней нет ничего сложного и, я думаю, уже сейчас вы это понимаете. Также тут можно применить достаточно популярное упрощение: HIN1 мы соединяем с LIN2, а HIN2 мы соединяем с LIN1, тем самым мы получаем управление всеми 4 ключами используя всего 2 входных сигнала, вместо 4, это показано на рисунке 8.


Рисунок 8 — Схема с IR2110 для высоковольтного полного моста с управлением ключами двумя входами (кликабельно)


Рисунок 9 — Схема с IR2110 как высоковольтного драйвера верхнего уровня

На рисунке 9 мы видим IR2110 использованный как драйвер верхнего уровня. Схема достаточно проста и имеет такую же функциональность как было описано выше. Есть вещь которую нужно учесть — так как мы больше не имеем ключа нижнего уровня, то должна быть нагрузка подключённая с OUT на землю. Иначе усилительный конденсатор не сможет зарядится.


Рисунок 10 — Схема с IR2110 как драйвера нижнего уровня


Рисунок 11 — Схема с IR2110 как двойного драйвера нижнего уровня


Если у вас проблемы с IR2110 и всё постоянно выходит из строя, горит или взрывается, то я уверен, что это из-за того, что вы не используете резисторы на затвор-исток, при условии, конечно, что вы всё спроектировали тщательно. НИКОГДА НЕ ЗАБЫВАЙТЕ О РЕЗИСТОРАХ НА ЗАТВОР-ИСТОК. Если вам интересно, вы можете прочитать о моем опыте с ними здесь (я также объясняю причину, по которой резисторы предотвращают повреждения): http://tahmidmc.blogspot.com/2012/10/magic-of-knowledge.html

Для дальнейшего чтения я рекомендую это: http://www.irf.com/technical-info/appnotes/an-978.pdf

Я видел как на многих форумах, люди бьются с проектированием схем на IR2110. У меня тоже было много трудностей прежде чем я cмог уверенно и последовательно строить успешные схемы драйвера на IR2110. Я попытался объяснить применение и использование IR2110 довольно тщательно, попутно всё объясняя и используя большое количество примеров, и я надеюсь, что это поможет вам в ваших начинаниях с IR2110.

habr.com

Как составить схему предложения: основные виды с примерами

Раз вы тут оказались, наверняка вы школьник, которому надо составить схему предложения. Это стандартное домашнее задание. Схема обычно делается в рамках синтаксического разбора предложения, но бывает и отдельно.

Предлагаю пройти тест – ответить на пять вопросов по схеме предложения.

[quiz-cat id=”2243″]

Ну как, что получили? А теперь объяснения.

Алгоритм составления схемы предложения

  1. Внимательно прочитайте предложение.
  2. Найдите подлежащее и сказуемое – грамматическую основу предложения. Грамматических основ может быть и несколько, в этом случае предложение сложное. Подчеркните подлежащее одной чертой и сказуемое двумя чертами.
  3. Определите, простое или сложное предложение.
  4. Обозначьте границы предложений вертикальными черточками. Отметьте границы простых предложений.
  5. Для сложных предложений определите союзную связь: сложносочиненное или сложноподчиненное предложение. Сочинительный или подчинительный союз.
  6. Выделите деепричастный и причастный оборот, если есть.
  7. Найдите второстепенные члены предложения. Подчеркните их так:
    • определение – волнистая линия
    • дополнение – пунктир;
    • обстоятельство – точка, тире, точка, тире;
    • деепричастный оборот – точка, тире, точка, тире, выделяется с двух сторон вертикальными чёрточками;
    • причастный оборот – волнистая линия, выделяется с двух сторон вертикальными чертами.

Графические обозначения

Главное предложение обозначается квадратными скобками, а придаточное – круглыми.

Настя сказала, что она пошла домой.

[-=],(что…).

Графические обозначения в схеме

Еще примеры с круглыми и квадратными скобками к схемам на рисунке. Все это сложноподчиненные предложения:

Настя шла и молилась, чтобы мама ее не ругала.

[-==],(чтобы…).

Когда Настя засобиралась домой, пошел снег.

(Когда…),[=-].

В том городе, где находится дом Насти, пошел снег.

[…,(где),=-].

Схема простого предложения

А теперь вернемся к простым предложениям. Начнем с самого простого:

Настя шла.

[-=].

Это простое предложение, проще некуда. Нераспространенное, так как в нем есть  только подлежащее и сказуемое.  Двусоставное, так как оба – и подлежащее, и сказуемое – есть.

Вот это уже распространенное предложение, так как помимо главных членов, есть второстепенный член:

Настя шла домой.

[-=…].

Приведу также примеры односоставных предложения. В них присутствует только один член – либо подлежащее, либо сказуемое. Первое предложение – назывное, главный член – подлежащее:

Снег.

[-].

Вот безличное односоставное предложение,  где главный член – сказуемое:

Вечереет.

[=].

Вот определенно-личное предложение, в котором главный член – сказуемое.

Желаю тебе добра.

[=…].

Но все эти детали (безличное, неопределенно-личное) в школе запоминать не надо, главное указать подлежащее со сказуемым. Что такое односоставные предложения вообще-то проходят в каком-то классе, но безличные они или неопределенно-личные, по-моему, уже не проходят.

Бывают еще простые и сложные сказуемые. Простое:

Настя собиралась домой.

[-=…].

Далее сложное глагольное. Здесь глагол один – “собиралась идти”. Не дайте ввести себя в заблуждение двумя словами, из которых он состоит:

Настя собиралась идти домой.

[-=…].

И сложное именное:

Настя рада быть полезной.

[-=…].

Схемы с обращениями и вводными словами

Настя, иди уже домой!

[|O|,…]!

В схеме обращения обозначаются O и обособляются вертикальными черточками. Обращения не являются членами предложения, потому и обособляются черточками. Они могут быть расположены в любом месте предложения. В схему обычно переносятся стоящие при них знаки препинания.

Пожалуйста, Настя, иди уже домой!

[…|O|,…]!

Вводные слова тоже не являются членами предложения и обособляются вертикальными линиями. Обозначаются они ВВ:

Кажется, Насте пора домой.

[|ВВ|,…].

Схемы с причастными и деепричастными оборотами

“Выйдя из дома” – деепричастный оборот ДО:

Выйдя из дома, Настя внезапно остановилась.

[|ДО|,…].

“постепенно сгущавшийся” – причастный оборот ПО:

Туман, постепенно сгущавшийся, делал передвижение Насти трудным.

[X,|ПО|,…].

Крестиком тут обозначено главное слово “туман”. Туман какой? Постепенно сгущавшийся. От него задается вопрос, потому это главное слово.

Деепричастный оборот может стоять в любом месте:

Настя, выйдя из дома, внезапно остановилась.

[…|ДО|,…].

Схемы с прямой речью

В таких схемах обозначаются границы, прямая речь, слова автора и стоящие при них знаки препинания. Например:

“Настя, или домой!” – громко сказал кто-то.

«[П!]»- [а].

Кто-то сказал: “Настя, или домой!”.

[A]:«[П!]»

Кто-то сказал: “Настя, или домой!” – и Петя не возразил.

[A]:«[П!]» – [a].

Схема сложного предложения

В сложносочиненном предложении обе части равноправны, ни одна не подчинена другой.

Вот сложносочиненное предложение с союзом “а”:

Настя шла, а туман застилал ей дорогу.

[-=],а [-=].

А вот сложносочиненное предложение с союзом “и”:

Снег падал, и ветер усилился.

[-=],и [-=].

 Сложносочиненное бессоюзное:

Снег падал, темнело.

[-=],[=].

В сложноподчиненном предложении есть главное и придаточное, поэтому иногда схемы составляют вертикально, если уровней зависимости несколько. Главное – в квадратных скобках, зависимое – в круглых:

Насте рассказали, что ее ждет испытание.

[-=],(что…).

Если еще уточнить, какое именно испытание ее ждет, получится три уровня:

Насте рассказали, что ее ждет испытание, которое определит ее жизнь.

[-=],(что…),(которое…).

Тут обе пары круглых скобок выглядят одинаково, тогда как на деле “какое испытание” – это второй уровень вложенности. Сначала “что ждет” – “испытание”. Потом “какое” – “которое определит”:

[-=],
(что…),
(которое…).

Но не всегда несколько придаточных предложений означают, что они все на разных уровнях. Два придаточных могут быть второстепенными по отношению к главному, но абсолютно равны между собой:

Когда Петя подошел, Настя прищурилась, чтобы лучше рассмотреть его.

(когда…),[-=],(чтобы…).

Настя прищурилась когда? Когда Петя подошел.

Настя прищурилась зачем? Чтобы лучше рассмотреть его.

Оба придаточных относятся к “Настя прищурилась” – уточняют зачем и когда она это сделала. А не одно придаточное уточняет другое придаточное. Оба равноправны, так как каждое уточняет главное:

[-=],
(когда…),        (чтобы…).

 

itlang.ru

Как создавать понятные логические (L3) схемы сети / Habr

Cамая большая проблема, с которой я сталкиваюсь при работе с сетями предприятий — это отсутствие чётких и понятных логических схем сети. В большинстве случаев я сталкиваюсь с ситуациями, когда заказчик не может предоставить никаких логических схем или диаграмм. Сетевые диаграммы (далее L3-схемы) являются чрезвычайно важными при решении проблем, либо планировании изменений в сети предприятия. Логические схемы во многих случаях оказываются более ценными, чем схемы физических соединений. Иногда мне встречаются «логически-физически-гибридные» схемы, которые практически бесполезны. Если вы не знаете логическую топологию вашей сети, вы слепы. Как правило, умение изображать логическую схему сети не является общим навыком. Именно по этой причине я пишу эту статью про создание чётких и понятных логических схем сети.

Какая информация должна быть представлена на L3-схемах?

Для того, чтобы создать схему сети, вы должны иметь точное представление о том, какая информация должна присутствовать и на каких именно схемах. В противном случае вы станете смешивать информацию и в итоге получится очередная бесполезная «гибридная» схема. Хорошие L3-схемы содержат следующую информацию:
  • подсети
    • VLAN ID (все)
    • названия VLAN'ов
    • сетевые адреса и маски (префиксы)

  • L3-устройства
    • маршрутизаторы, межсетевые экраны (далее МСЭ) и VPN-шлюзы (как минимум)
    • наиболее значимые серверы (например, DNS и пр.)
    • ip-адреса этих серверов
    • логические интерфейсы

  • информацию протоколов маршрутизации

Какой информации НЕ должно быть на L3-схемах?

Перечисленной ниже информации не должно быть на сетевых схемах, т.к. она относится к другим уровням [модели OSI, прим. пер.] и, соответственно, должна быть отражена на других схемах:
  • вся информация L2 и L1 (в общем случае)
  • L2-коммутаторы (может быть представлен только интерфейс управления)
  • физические соединения между устройствами

Используемые обозначения

Как правило, на логических схемах используются логические символы. Большинство из них не требуют пояснений, но т.к. я уже видел ошибки их применения, то позволю себе остановиться и привести несколько примеров:
  • Подсеть, представленная как трубка или линия:

  • VRF или другая не известная точно зона представляется в виде облака:


Какая информация необходима для создания L3-схемы?

Для того, чтобы создать логическую схему сети, понадобится следующая информация:
  • Схема L2 (или L1) — представление физических соединений между устройствами L3 и коммутаторами
  • Конфигурации устройств L3 — текстовые файлы либо доступ к GUI, и т.д.
  • Конфигурации устройств L2 — текстовые файлы либо доступ к GUI, и т.д.
Пример

В данном примере мы будем использовать простую сеть. В ней будут присутствовать коммутаторы Cisco и МСЭ Juniper Netscreen. Нам предоставлена схема L2, также как и конфигурационные файлы большинства представленных устройств. Конфигурационные файлы пограничных маршрутизаторов ISP не предоставлены, т.к. в реальной жизни такую информацию ISP не передаёт. Ниже представлена L2-топология сети:

А здесь представлены файлы конфигурации устройств. Оставлена только необходимая информация:

asw1

!
vlan 210
name Servers1
!
vlan 220
name Servers2
!
vlan 230
name Servers3
!
vlan 240
name Servers4
!
vlan 250
name In-mgmt
!
interface GigabitEthernet0/1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/2
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface vlan 250
ip address 192.168.10.11 255.255.255.128
!
ip default-gateway 192.168.10.1


asw2

!
vlan 210
name Servers1
!
vlan 220
name Servers2
!
vlan 230
name Servers3
!
vlan 240
name Servers4
!
vlan 250
name In-mgmt
!
interface GigabitEthernet0/1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/2
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface vlan 250
ip address 192.168.10.12 255.255.255.128
!
ip default-gateway 192.168.10.1


asw3

!
vlan 210
name Servers1
!
vlan 220
name Servers2
!
vlan 230
name Servers3
!
vlan 240
name Servers4
!
vlan 250
name In-mgmt
!
interface GigabitEthernet0/1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/2
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface vlan 250
ip address 192.168.10.13 255.255.255.128
!
ip default-gateway 192.168.10.1


csw1

!
vlan 200
name in-transit
!
vlan 210
name Servers1
!
vlan 220
name Servers2
!
vlan 230
name Servers3
!
vlan 240
name Servers4
!
vlan 250
name In-mgmt
!
interface GigabitEthernet0/1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/2
switchport mode trunk
switchport trunk encapsulation dot1q
channel-group 1 mode active
!
interface GigabitEthernet0/3
switchport mode trunk
switchport trunk encapsulation dot1q
channel-group 1 mode active
!
interface GigabitEthernet0/4
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/5
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/6
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface Port-channel 1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface vlan 200
ip address 10.0.0.29 255.255.255.240
standby 1 ip 10.0.0.28
!
interface vlan 210
ip address 192.168.0.2 255.255.255.128
standby 2 ip 192.168.0.1
!
interface vlan 220
ip address 192.168.0.130 255.255.255.128
standby 3 ip 192.168.0.129
!
interface vlan 230
ip address 192.168.1.2 255.255.255.128
standby 4 ip 192.168.1.1
!
interface vlan 240
ip address 192.168.1.130 255.255.255.128
standby 5 ip 192.168.1.129
!
interface vlan 250
ip address 192.168.10.2 255.255.255.128
standby 6 ip 192.168.10.1
!
ip route 0.0.0.0 0.0.0.0 10.0.0.17


csw2

!
vlan 200
name in-transit
!
vlan 210
name Servers1
!
vlan 220
name Servers2
!
vlan 230
name Servers3
!
vlan 240
name Servers4
!
vlan 250
name In-mgmt
!
interface GigabitEthernet0/1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/2
switchport mode trunk
switchport trunk encapsulation dot1q
channel-group 1 mode active
!
interface GigabitEthernet0/3
switchport mode trunk
switchport trunk encapsulation dot1q
channel-group 1 mode active
!
interface GigabitEthernet0/4
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/5
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/6
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface Port-channel 1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface vlan 200
ip address 10.0.0.30 255.255.255.240
standby 1 ip 10.0.0.28
!
interface vlan 210
ip address 192.168.0.3 255.255.255.128
standby 2 ip 192.168.0.1
!
interface vlan 220
ip address 192.168.0.131 255.255.255.128
standby 3 ip 192.168.0.129
!
interface vlan 230
ip address 192.168.1.3 255.255.255.128
standby 4 ip 192.168.1.1
!
interface vlan 240
ip address 192.168.1.131 255.255.255.128
standby 5 ip 192.168.1.129
!
interface vlan 250
ip address 192.168.10.3 255.255.255.128
standby 6 ip 192.168.10.1
!
ip route 0.0.0.0 0.0.0.0 10.0.0.17


fw1

set interface ethernet0/1 zone untrust
set interface ethernet0/1.101 tag 101 zone dmz
set interface ethernet0/1.102 tag 102 zone mgmt
set interface ethernet0/2 zone trust
set interface ethernet0/1 ip 10.0.0.1/28
set interface ethernet0/1 manage-ip 10.0.0.2
set interface ethernet0/1.101 ip 10.0.0.33/28
set interface ethernet0/1.102 ip 10.0.0.49/28
set interface ethernet0/2 ip 10.0.0.17/28
set interface ethernet0/2 manage-ip 10.0.0.18
set vrouter trust-vr route 0.0.0.0/0 interface ethernet0/1 gateway 10.0.0.12


fw2

set interface ethernet0/1 zone untrust
set interface ethernet0/1.101 tag 101 zone dmz
set interface ethernet0/1.102 tag 102 zone mgmt
set interface ethernet0/2 zone trust
set interface ethernet0/1 ip 10.0.0.1/28
set interface ethernet0/1 manage-ip 10.0.0.3
set interface ethernet0/1.101 ip 10.0.0.33/28
set interface ethernet0/1.102 ip 10.0.0.49/28
set interface ethernet0/2 ip 10.0.0.17/28
set interface ethernet0/2 manage-ip 10.0.0.19
set vrouter trust-vr route 0.0.0.0/0 interface ethernet0/1 gateway 10.0.0.12


outsw1

!
vlan 100
name Outside
!
vlan 101
name DMZ
!
vlan 102
name Mgmt
!
interface GigabitEthernet1/0
description To-Inet-rtr1
switchport mode access
switchport access vlan 100
!
interface GigabitEthernet1/1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet1/3
switchport mode trunk
switchport trunk encapsulation dot1q
channel-group 1 mode active
!
interface GigabitEthernet1/4
switchport mode trunk
switchport trunk encapsulation dot1q
channel-group 1 mode active
!
interface Port-channel 1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface vlan 102
ip address 10.0.0.50 255.255.255.240
!
ip default-gateway 10.0.0.49


outsw2

!
vlan 100
name Outside
!
vlan 101
name DMZ
!
vlan 102
name Mgmt
!
interface GigabitEthernet1/0
description To-Inet-rtr2
switchport mode access
switchport access vlan 100
!
interface GigabitEthernet1/1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet1/3
switchport mode trunk
switchport trunk encapsulation dot1q
channel-group 1 mode active
!
interface GigabitEthernet1/4
switchport mode trunk
switchport trunk encapsulation dot1q
channel-group 1 mode active
!
interface Port-channel 1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface vlan 102
ip address 10.0.0.51 255.255.255.240
!
ip default-gateway 10.0.0.49

Сбор информации и её визуализация

Хорошо. Теперь, когда мы имеем всю необходимую информацию, можно приступать к визуализации.
Процесс отображения шаг за шагом

  1. Сбор информации:
    1. Для начала откроем файл конфигурации (в данном случае ASW1).
    2. Возьмём оттуда каждый ip-адрес из разделов интерфейсов. В данном случае есть только один адрес (192.168.10.11) с маской 255.255.255.128. Имя интерфейса — vlan250, и имя vlan 250 — In-mgmt.
    3. Возьмём все статические маршруты из конгфигурации. В данном случае есть только один (ip default-gateway), и он указывает на 192.168.10.1.

  2. Отображение:
    1. Теперь давайте отобразим информацию, которую мы собрали. Во-первых, нарисуем устройство ASW1. ASW1 является коммутатором, поэтому используем символ коммутатора.
    2. Нарисуем подсеть (трубку). Назначим ей имя In-mgmt, VLAN-ID 250 и адрес 192.168.10.0/25.
    3. Соединим ASW1 и подсеть.
    4. Вставляем текстовое поле между символами ASW1 и подсети. Отобразим в нём имя логического интерфейса и ip-адрес. В данном случае имя интерфейса будет vlan250, и последний октет ip-адреса — .11 (это является общей практикой — отображать только последний октет ip-адреса, т.к. ip-адрес сети уже присутствует на схеме).
    5. Также в сети In-mgmt есть другое устройство. Или, как минимум, должно быть. Нам ещё неизвестно имя этого устройства, но его IP-адрес 192.168.10.1. Мы узнали это потому, что ASW1 указывает на этот адрес как на шлюз по-умолчанию. Поэтому давайте отобразим это устройство на схеме и дадим ему временное имя "??". Также добавим его адрес на схему — .1 (кстати, я всегда выделяю неточную/неизвестную информацию красным цветом, чтобы глядя на схему можно было сразу понять, что на ней требует уточнения).


На этом этапе мы получаем схему, подобную этой:

Повторите этот процесс шаг за шагом для каждого сетевого устройства. Соберите всю информацию, относящуюся к IP, и отобразите на этой же схеме: каждый ip-адрес, каждый интерфейс и каждый статический маршрут. В процессе ваша схема станет очень точной. Убедитесь, что устройства, которые упомянуты, но пока неизвестны, отображены на схеме. Точно так же, как мы делали ранее с адресом 192.168.10.1. Как только вы выполните всё перечисленное для всех известных сетевых устройств, можно начать выяснение неизвестной информации. Вы можете использовать для этого таблицы MAC и ARP (интересно, стоит ли писать следующий пост, рассказывающий подробно об этом этапе?).

В конечном счёте мы будем иметь схему наподобие этой:

Заключение

Нарисовать логическую схему сети можно очень просто, если вы обладаете соответствующими знаниями. Это продолжительный процесс, выполняемый вручную, но это отнюдь не волшебство. Как только у вас есть L3-схема сети, достаточно нетрудно поддерживать её в актуальном состоянии. Получаемые преимущества стоят приложенных усилий:
  • вы можете планировать изменения быстро и точно;
  • решение проблем занимает гораздо меньше времени, чем до этого. Представим, что кому-то нужно решить проблему недоступности сервиса для 192.168.0.200 до 192.168.1.200. После просмотра L3-схемы можно с уверенностью сказать, что МСЭ не является причиной данной проблемы.
  • Вы можете легко соблюдать корректность правил МСЭ. Я видел ситуации, когда МСЭ содержали правила для трафика, который никогда бы не прошёл через этот МСЭ. Этот пример отлично показывает, что логическая топология сети неизвестна.
  • Обычно как только L3-схема сети создана, вы сразу заметите, какие участки сети не имеют избыточности и т.д. Другими словами, топология L3 (а также избыточность) является такой же важной как избыточность на физическом уровне.

habr.com

Профессиональное построение блок-схем для программ / Sandbox / Habr

Здравствуйте, хабралюди! Сегодня речь пойдет о построении блок-схем для ваших программ с помощью замечательной программы yEd скачать которую можно здесь .
Приступая к работе

Не спешите скачивать, давайте проведем маленькую лекцию по этим же блок-схемах.

Блок-схема это графическое отображение решения задачи (важно запомнить).

И так, буду объяснять как программист программисту, по моему мнению блок-схемы можно использовать когда алгоритм не реально держать в голове (10-20 if else) вот тогда то и приходит такая мысль как записать это, в тот же блокнот, или на бумаге, что вполне приемлемо и ничего такого здесь нет. В нашем случае давайте использовать блок-схемы.

Обозначения


Такой овал обозначает обычно начало и конец, к примеру .

Данный блок обозначает объявление переменных. Если у вас сильно типизированный язык программирования то этот блок обычно всегда есть в ваших программах, лично я использую слабо типизированные что позволяет мне объявить тип и название переменной сразу при присваивании её какому-то значению.

Собственно вывод результат на экран или продолжение следующего действия.

Ну, и наконец, наше условие ради чего мы здесь и собрались. Может принимать только true or false.

А теперь запускаем yEd
file -> new
По средине будет наша блок-схема, а вот справа отображены наши элементы которые нам будут нужны.
Перетаскивать элементы можно справа на белый лист, что бы провести стрелочку нужно: на элемент, который стоит по средине нажать и отвести мышку от него, при этом в поле edge types можно выбрать тип стрелочки. Вот так у меня получилось реализовать авторизацию пользователя на сайте в помощью блок-схемы:
image

Заняло у меня это 5 минут. Но за то теперь я точно знаю что и как мне нужно будет делать. А когда программа сложная то сделав блок-схему уже можешь сразу писать код и не заглядывая туда, т.к. только что сам написал эту программу, но визуально!
Вообщем блок-схемы это круто!

habr.com

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *